SermonSpeaker Extension Welcome Image

Login Form

SermonSpeaker 3.4.4 is released. This release contains support for jUpgrade which should make it easier to migrate SermonSpeaker to 4.0 (and Joomla! 2.5).

jUpgrade

jUpgrade is a Joomla! 1.5 extension which will migrate your Joomla! 1.5 site to Joomla! 2.5. It does all the database changes and downloads and installs the new Joomla for you. It will do so for all core extensions and some 3rd party extensions. Now it will also copy the SermonSpeaker tables.

However the thing is a bit buggy and so I couldn't get it to directly install SermonSpeaker 4.0 and migrate the SermonSpeaker categories. So to migrate SermonSpeaker you still need to install SermonSpeaker 4.0 manually and recreate the categories.

Mew migration plan:

  1. Install SermonSpeaker 3.4.4
  2. Run jUpgrade
  3. Install SermonSpeaker 4.0 (not a newer release!), check if sermons are there
  4. Update to latest SermonSpeaker release
  5. Recreate SermonSpeaker categories and menu items